18.6.3. Plugin versioning

The version number of the plugin and the PSM API must be in the form <major number>.<minor number>. Note the following points about version number:

  • PSM supports only a single version of the plugin API.

  • The major version number of the api field in the plugin must be the same as the major version number of the PSM API.

  • The minor version number of the api field in the plugin cannot be higher than the minor version number of the PSM API.

For example, if the API version of PSM is 1.3, then PSM can use plugins with version number 1.0, 1.1, 1.2, and 1.3.

Warning

Currently, the API version number must be 1.0.